1. How to Get Started
    1. Sign Up for a Free Trial
    2. Update Your Profile Page
    3. Connect a Data Source
      1. Connecting your own Data Source
      2. Connecting a Demo Data Source
    4. Refresh Your Data Source
    5. Delete a Connected Data Source
    6. Adjust Decimal Place & Ratio Settings
    7. Connect Weather Data
    8. Notifications
      1. Email & SMS
      2. In-App Notifications
  2. How to Create Organizations & Invite Users
    1. Partners
      1. How to Set Up Your Partner Organization
        1. Add Your Logo & Branding
        2. Collaborate with Your Team
        3. Collaborate with Your Clients
          1. Create a New Client Organization
          2. Invite Team Members to Client Organizations
          3. Invite Your Clients
    2. Business Owners
      1. How to Set Up Your Organization
      2. Collaborate with Your Team
    3. User Administration
      1. User permissions
      2. Edit User Permissions
      3. Assign the Payment Manager
  3. How to Use Data Chat
    1. What is a query?
    2. Query Builder
    3. Ask chata.ai
    4. Ask Your Own Questions
      1. Recommendation Engine
      2. Interpretation Confirmation
      3. Identifying Spelling Errors
    5. Saving Results
      1. Pins
    6. Tool Bar
      1. Edit Table
      2. Download Image
      3. Copy to Clipboard
      4. Full Screen
      5. Comment
      6. Delete Query
      7. Dynamic Stats
  4. How to Use Reports
    1. Report Templates
      1. Create a Template
      2. Edit a Template
      3. Share Templates
    2. Create a Report from a Report Template
    3. Save a Report from Data Chat
    4. Comments & Text Boxes
    5. Edit a Report
    6. Share Reports
    7. Schedule Reports
    8. Export to PDF
  5. How to Use Dashboards
    1. Create a Dashboard
      1. Share Dashboards
      2. Edit a Dashboard
        1. Add a New Tile
        2. Edit the Query Displayed in a Tile
        3. Edit the Data Source Displayed in a Tile
        4. Edit the Title of a Tile
        5. Resizing Tiles
        6. Arranging Tiles
        7. Delete a Tile
    2. Viewing Multiple Dashboards
    3. Downloading & Copying Tiles from a Dashboard
    4. Delete a Dashboard
  6. How to Use Data Visualizations
    1. Create Dynamic Graphs
    2. Create Visualizations with Queries
    3. Drill Down into Your Data
    4. Types of Charts & Graphs
      1. Pivot Table
      2. Filter Table
      3. Line Graph
      4. Pie Chart
      5. Bar Chart
      6. Column Chart
      7. Stacked Bar/Column Chart
      8. Heatmap
      9. Bubble chart
      10. Word Cloud
  7. How to Use Cash Flow Forecasting
    1. Calculating Cash Flow Forecasts
    2. Calculating High and Low Estimated Predictions
    3. Reading a Rolling Forecast
    4. Making Manual Adjustments
    5. Viewing Cash Flow Graphs
      1. Zoom View
      2. Viewing Individual Line Graphs
    6. Is Your Data Compatible with Our System?
  8. Billing & Licences
    1. Upgrade a Data Source to Premium
    2. Purchase Licences
    3. Assign a Purchased Licence
    4. View Your Purchase Summary

How to Get Started

Our integrations with QuickBooks Online, Xero and Stripe are complete! You can now incorporate cutting-edge AI into your business.

You only need a few minutes to connect your data source and start chatting with your data!

Let us know how we can help.

Sign Up for a Free Trial

To create an account with chata.ai is very simple, just follow the step-by-step below.

  1. Fill out all of the required fields and agree to the terms and conditions. Select “Sign me up as a Partner” if you are an accountant or bookkeeper and would like to bring chata.ai to your clients.  Learn more about the benefits of becoming a chata.ai Partner.

  1. You will receive an email asking you to complete your registration. If you don’t see this email shortly after registration, please check your junk mail. Once you respond to this email you will be asked to set up your profile and password with chata.ai

 

Update Your Profile Page

You can update your personal information at any time, or add a profile image and customize display name. 

  1. Click on your avatar at the top right side of the page.
  2. Select Profile. 
  3. Edit your profile image by clicking on the avatar. Choose one of our icons or upload your own photo.
  4. Edit your personal information or update your contact information and password whenever you need to.
  5. Select how you would like to receive notifications when someone shares a Report with you.
  6. Choose between Light or Dark theme to suit your preferences.

 

 

Connect a Data Source

Connecting your own Data Source

Once you have completed your registration, connect your first Data Source.

    1. Select Settings in the left side menu.
    2. Click Add New Data Source.
    3. Select Connect Your Own Data.
    4. Select the Data Source type (ex. Xero) you wish to connect.
      Note for chata.ai Partners: The Organization field will already be selected for you. If the pre-selected organization is not the organization you wish to connect the Data Source to, simply select another Organization from the dropdown menu or create a New Client Organization if you are adding this Data Source to a new Client Organization. Then select Next.
    5. Select the location of the business associated with the Data Source in order to Link Weather Data. Select Celsius or Fahrenheit and click Next. You can Skip this step if you do not wish to link your Data Source to weather data.
    6. Select your Time Zone and click
    7. Click Connect to [Data Source] to complete the authentication process.For QuickBooks Online, Xero, and Stripe Data Sources: You will be prompted to log in to your respective account with your username and password. You will only need to do this once for each Data Source. After the connection is complete, chata.ai will automatically refresh your data in-app every day.

IMPORTANT NOTE: Depending on the size of your dataset, it can take up to 15 minutes to connect to your Data Source. Do not close the window while your Data Source is connecting as the connection process will be interrupted.

Connecting a Demo Data Source

Once you have completed your registration, you have the option to connect to a Demo Data Source.

  1. Select Settings in the left side menu.
  2. Click Add New Data Source.
  3. Select Connect a Demo Data Source.
  4. Select the Demo Data Source type (ex. QBO) you wish to connect.
    For chata.ai Partners: The Organization field will already be selected for you. If the pre-selected organization is not the organization you wish to connect the Demo Data Source to, simply select another Organization from the dropdown menu or create a New Client Organization if you are adding this Demo Data Source to a new Client Organization. Then select Next.
  5. Click Connect to [Data Source] to add the Demo Data Source to your account.

PLEASE NOTE: Depending on the size of the dataset, it can take up to 15 minutes to connect to a Data Source. Do not close the window while the Data Source is connecting as the connection process will be interrupted.

Refresh Your Data Source

chata.ai dynamically refreshes your data daily. If the information in your connected software application has been updated in between automatic refreshes, and you want these changes to be reflected in chata.ai, select the “refresh” icon beside the data source in the Settings page. 

Delete a Connected Data Source

To delete a Data Source from your chata.ai account go to Settings in the left side menu and click on the Trash Can icon beside the data source.

PLEASE NOTE: If you have Admin or Connect permission, any shared Data Sources will be deleted for all collaborating users. The Reports you’ve made using the Data Source will be saved, but any Dashboards or Report Templates will no longer display data from the deleted Data Source.

Adjust Decimal Place & Ratio Settings

There are two ways to change how your numbers are displayed in the tables that chata.ai creates.

To change how many decimal places are displayed for a whole Data Source:

  1. Select Settings beside the desired Data Source.
  2. Select the number of decimal places you want to view consistently.

To change the number of decimal places and to display percentages please see the Edit Table section of this document.

Connect Weather Data

If you did not connect weather data when you added the Data Source, you can connect it later by following these instructions:

  1. Select Settings beside the desired Data Source
  2. Type in the location of the business that Data Source is associated with.
  3. Select the location from the drop down menu.
  4. Verify that the location is correct using the map.
  5. Click Apply at the bottom of the screen.

Notifications

You can receive notifications both inside the application and via email or SMS text.

Email & SMS

You can opt into email & SMS notifications by navigating to your Profile and updating the Notification Settings. You will only receive a notification to your email or smartphone if someone shares a Report with you. This notification will prompt you to log into chata.ai and view the Report.

In-App Notifications

In-app notifications alert you if a Report has been shared with you or if another user makes a comment has been made. Notifications appear over the megaphone icon in the top right of the screen. Click the icon to view your notifications.

 

How to Create Organizations & Invite Users

Partners

Partners are our accountant and bookkeeper users. Setup will look different for users who intend to use chata.ai as part of their financial services practice, so if you’re intending to use chata.ai for your own business data, head down to the Business Owner section of this document.

How to Set Up Your Partner Organization

There are certain features that we have created in chata.ai to help our Partner users to better collaborate with their customers

Add Your Logo & Branding

In a Partner Organization, select “Settings” and navigate to the tab titled “Partner Customization”. Select “Upload logo” and choose your logo.

Note: You will only have the option to add a logo if you are an admin user.

Collaborate with Your Team

Your staff are considered Partners within chata.ai, so everyone on your team always has free access to your client’s Data Source. In order to have access, team members must be added as users to the Partner Organization (your firm). To add a new Partner to your Partner Organization, click Settings in the left side menu, click the User Administration tab at the top,  select Invite User and add the User.

You can give them access to the firm data source by checking the box underneath that data source. Give your staff the appropriate permissions.  You can now add your clients to the appropriate client organizations & data sources.

Collaborate with Your Clients

Create a New Client Organization

An Organization is a company or business. If you are a chata.ai Partner, you will likely have many Client Organizations, including your own Home Organization which is where your firm’s data source(s) live. If you are an owner of multiple businesses, you will also likely have more than one Organization within your chata.ai account.

To add an organization:

  1. Select the plus icon beside your Home or Partner Organization at the top of the screen on the left side.
  2. Name this Organization and take the option to add clients or additional users now or later.
  3. You will be taken to this Organization in chata.ai and you can complete the same data connection process you went through for your initial Data Source.

To navigate between Organizations, select the dropdown arrow beside the Organization name on the top left side of the interface and select the Organization that you want to explore.

Invite Team Members to Client Organizations

To invite Partners to Client Organizations, first they must be added as users to the Partner Organization.

  1. Go to a Client Organization
  2. Select Settings in the left side menu
  3. Click the User Administration tab at the top
  4. Select ‘Invite Partners’
  5. Select the Partners you wish to add
  6. Click Invite
  7. Make sure they have access to the data source.

This process must be repeated for each client organization.

Invite Your Clients

  1. Go to a Client Organization
  2. Select Settings in the left side menu
  3. Click the User Administration tab at the top
  4. Select ‘Invite User’
  5. Enter the required Client information
  6. Give the User appropriate Permissions
  7. Make sure they have access to the data source

Business Owners

Business Owners are users who intend to use chata.ai for their own business data. If you’re an accountant or bookkeeper intending to use chata.ai as part of your financial service practice, please visit the Partners section of this document.

How to Set Up Your Organization

To set up your chata.ai account for your business. All you need to do is connect the data sources you want to query and add your team and/or advisors.

Collaborate with Your Team

  1. Select Settings in the left side menu
  2. Click the User Administration tab at the top
  3. Select ‘Invite User’
  4. Enter the required Client information
  5. Give the User appropriate Permissions
  6. Make sure they have access to the data source

User Administration

User permissions

Edit User Permissions

In settings, under User Administration, edit a user’s permissions by selecting the pencil icon underneath their name. A modal will pop up where you can select Admin, Connect, Standard or Read-Only Permissions.

Assign the Payment Manager

To assign a payment manager, select the pencil icon underneath the user’s name. In the same modal where you selected user permissions, select the box beside “Billing” at the bottom of the modal.

How to Use Data Chat

What is a query?

A query is how you communicate with chata.ai using your natural “human” language. chata.ai takes this query and automatically translates it to a form that your database will understand and can execute on. You can ask simple to complex questions about your business data. Visit our Query Tips page and our Query News Flash blog for resources to get started on your querying.

Query Builder

To help you get started how to create a query, we created “Query Builder”. To use Query Builder, follow these steps:

  1. Select if you want to view a “list” (all) of transactions or a “calculation” (total or average).
  2. Select a topic
  3. Make further selections such as a “time range”, “time group”, and “other group”
  4. As you make selections, you will be provided options for queries to the right. Select one of these queries. chata.ai will type the query automatically into the query engine and pull the data directly from your data source in seconds.

 

Ask chata.ai

  1. Hover over the hamburger menu at the bottom of the screen
  2. Select “ask chata.ai”
  3. chata.ai will type a random query and pull the data directly from your data source

Ask Your Own Questions

To create your own query, first select which data source you want your data to come from. Then, type your question into the “Ask me anything” field and hit Enter.

Recommendation Engine

You will notice there are recommendations for your query, if it makes sense, you can select one of these options by clicking it with your mouse or using the arrow keys to highlight the applicable query suggestion before hitting Enter.

Interpretation Confirmation

As humans, we can ask the same question in multiple ways and expect the same result. If you want to know how chata.ai interpreted your query, you can click on the chata.ai avatar beside the query answer. If this looks right you can click “Correct”, if something doesn’t look right you can click “Report a problem” and we will be notified to investigate and add training to our system.

Identifying Spelling Errors

It is easy to find the information you are looking for quickly, even when you misspell a word or Value Label.  

Value Labels are how different variables are labelled within your data. They include things like customer names, vendor names, product names, etc. 

If you misspell a word or Value Label, chata.ai will ask for more information prompting you to select the appropriate descriptor from a drop-down menu.  Once you have made your selection, hit “Run Query.”

 

Saving Results

Pins

During a session, you may only want to save specific query results and not the results of the entire session.  This is what pins are for.  When you pin your query result, the data will be saved and timestamped. If you add comments, these will be saved in the pinned query as well. You can think of a pinned query as a sticky note that can never get lost.

To pin a query and the results, click the pin icon on the right-hand side of the query box.  It will be white if the query/result has been pinned and will be filled in blue if the query/results have been pinned.

 

You can easily view all pins associated with that Data Source by selecting “Pins” under the reporting tab in the left-side menu. If you didn’t add comments when you originally pinned the query, you can add our comments when in the Pins tab as well. If you no longer require the query result to be pinned, you can unpin the saved query.

 

Tool Bar

When you query, you will notice there is a tool bar in the top right corner of your query answer. These tools will help you make the most of your data.

Edit Table

If your query response includes a table, you have the option to edit the table to best suit your needs. Click the “Edit table” icon.  

Select a column to edit. You have the option for the data in that column to be left, center or right aligned. Depending on the nature of the data in the column, you can select for the data to be displayed as a percentage or ratio; increase or decrease the number of decimal points or full delete the column.  

To change the title or header of the column, select the column then adjust the text. Be sure to click the “check” mark to save the updates. 

 

Download Image

To download an image to use in a presentation or report, select the “Save chart image” icon. The chart or graph will be downloaded as a PNG which you can save and use as you wish.

 

Copy to Clipboard

There are times that you may want to copy the data and move it into an external spreadsheet. To do this, just select the “Copy to clipboard” icon, and paste the data into your desired spreadsheet.

 

Full Screen

To view a larger version of your query response, you can select the “full screen” icon. This would be useful in a team strategy session for example, where you are analyzing your data with more than one person on a larger screen.

Comment

You can add comments to your queries to save with pins or reports. To add a comment, select the comment button, type your question, comment, insight or reminder, click save and you can view your comment right under your query answer. Note that your comment will not be saved unless you save the query as a Pin or in a Report.

 

Delete Query

To delete a query from your query session, click the trashcan icon in the toolbar.

Dynamic Stats

When more than one cell with numbers are selected, summary stats for those cells are displayed on the bottom left side of the query answer.

 

How to Use Reports

Reports are used to review a set of saved data from a specific point in time.  You can save a series of queries and results as a report from a query session or by running a template.  All reports will be timestamped, marking when the report was created. 

Report Templates

Report Templates are used to make it easy to run Reports for regular analysis.

Say you need to run a cash flow and AR report every month. Instead of setting up a new Report each month, you can create a Template once and run those queries time and time again.

You can also automate Templates to run as regular reports on a set schedule.

You can find Templates you have created under the My Templates folder. Find Templates shared with you under the Shared With Me folder.

Create a Template

 

  1. Hover over the “Template” icon on the left-side menu
  2. Select “New Template”
  3. Name your template
  4. Select “Add Query Tile” to start querying
    • Be sure to select the data source you want to query from
    • You can add titles to your tiles
  5. Select “Add Text Box” to add any supporting text to go along with query tile(s)
    • Adjust your text size
    • Change your font styling
    • Align your text
  6. Tiles can be resized by dragging the bottom right corner
  7. Templates will automatically save while editing
  8. Select “Stop editing” on the bottom right when you are finished

You can now press the “play” button to run your report.

Edit a Template

To edit a template:

  1. Select the template you wish to edit
  2. Select the “Pencil-edit” button at the bottom right hand corner of the interface
  3. Make your edits:
      • Add query tile
      • Add text box
      • Change your query or query title
      • Rearrange the position of the tiles
      • Resize the tiles
      • Delete tiles
  1. Select “Stop Editing” once you are finished editing.

Share Templates

If you want to share the templates with other users in your Organization or have access to a template in another Organization that you belong to, you must share the Template. To share the template:

  1. Hover over the template you wish to share in the left side menu
  2. Select the “Share” icon

  1. Select which organizations you want to share the template with
  2. Select if you want to make the template “Public” or “Private”

Public = All users in the organization can access the template

Private = You are the only user who can access the template

Technically these templates are your “IP” or “Intellectual Property” so it is up to you to decide whether to share these templates with your clients, team members or advisors.

You can access shared templates under the “Shared With Me” folder within the other organizations.

When you edit the Master Copy of the shared template, it will make changes to the shared template. To save the shared template and make adjustments for a specific organization, select “Save As”.

To make edits to all copies of the shared template, select “Navigate to Master Copy” and edit the Master Copy.

Create a Report from a Report Template

To save a Report from a Report Template, open and run the Template. Then, navigate to the bottom right corner of the page and select the save icon, select Save as Report, name the Report, and click Save.

 

Save a Report from Data Chat

To save a Report from a series of queries and results from a one-time session in Data Chat, navigate to the hamburger menu in the bottom left corner of Data Chat and select Save as Report.

Comments & Text Boxes

Add your comments to the query tile by selecting the comment icon at the top right corner of each tile. When you are done, just exit out of the pop-up.  The blue bubble on top of the query indicates the number of comments that exist for each queryOnce you’ve shared this report with your team, or clients you can communicate back and forth with this feature. 

Edit a Report

To edit a Report, select the edit icon on the bottom right hand side of the page.

You cannot change the displayed data or edit queries once you’ve saved a Report. You can change the title of a tile, the type of visualization, and add supplementary text boxes if you need to bring in additional information. You can also adjust the size of all tiles and rearrange them.  

To exit edit mode, select the stop editing icon in the bottom right corner of the page.  

NOTE: You can only edit the Reports you create. You will only be able to view Reports that are shared with you. 

 

  

Share Reports

To share a report with other users, click the share icon at the bottom of the interface or beside the desired report under the Reporting tab in the left side menu.

 

Select which users you want to share the report with and press “Share”.

 

The selected users will receive a notification via SMS or email that you have shared this report and be prompted to login to their chata.ai app to view the report. They can then add their comments.

Schedule Reports

We know automation is important to you in order to increase efficiency in your workflows. You can schedule your Templates to run reports automatically. All you have to do is click the “Save As” button at the bottom of a Template you have created to start scheduling. Then:

  1. Select a start date for the schedule. The default date will be the current date.
  2. To save this as a recurring scheduled report, click the “Repeat” check box to access the frequency
  3. Select daily, weekly, monthly, yearly or custom:
  • Daily: Report will run once a day at the selected time
  • Weekly: Report will run once every seven days at the selected time
  • Monthly: Report will run once a month on the current day at the selected time. You can check the selection “On the last day of the month” for the report to run on the last day of the month at the end of the day.
  • Yearly: The schedule will run once a year on the date and time selected
  • Custom: Select a custom time, day and frequency range
  1. Check the option “Specify End Date” to set an end date for the recurring report or leave it unchecked to have this scheduled Template run indefinitely.
  2. Name the report that the executed Template will be saved as. All reports for this schedule will have this same name. You can edit the name of the report after it has been saved.

To view your Scheduled Templates, go to “Templates” in the left side menu and select “Scheduled Templates”. You will see 2 sections here: Active Schedules and Completed Schedules. Completed Templates are Templates that will not be executed automatically again.

You can sort your schedules by Template Name, Report Name, Start Date or End Date to easily find the Template you are looking for.

Delete a report schedule at any time by clicking the trash can icon on the right side of the Template.

Other tips:

  • You can make as many schedules as you want for a single Template
  • Templates will run automatically as scheduled and will be saved as a report in the “My Reports” section in the Reporting tab
  • You can identify if a Template has been set as a scheduled report if there is the schedule icon beside the Template.

  • Templates that have a reporting schedule will also include an info bar at the top of the Template

You cannot edit a template that has a reporting schedule until the reporting schedule(s) has been deleted. You can make a copy of the Template to edit, this new Template will not have a reporting schedule until you set one.

Export to PDF

Select “PDF Preview” at the bottom left side of the page. You can make the following adjustments to your PDF export: 

  • Landscape or portrait view
  • Paper size
  • Report Description
  • Size of tiles and alignment on paper

Once your PDF looks great, go ahead and select “Download PDF”

 

How to Use Dashboards

A Dashboard is a completely customizable analytics and reporting tool that combines the power of Data Chat with easy-to-understand visualizations that display the most up-to-date information from your Data Sources.

Dashboards can give you a comprehensive snapshot of what is going on in a business from cash flow to inventory and beyond. They can help you monitor the financial and operational health of any aspect of a business that you’re curious about.

Once you’ve created your Dashboards, they can help you check in with your KPIs and critical metrics on a regular basis by automating the data collection and organization process, so you can access those numbers, faster.

You can create multiple Dashboards that display information from any combination of Data Sources.

You can drill down on any of the information displayed in your Dashboard tiles to get to the bottom of bottlenecks and pressing issues in seconds.

You can share your Dashboards with your team members or clients.

Dashboards dynamically refresh the information displayed in each tile, so the data you see in your Dashboards will shift as new information enters the system. If you would like to save and time-stamp data, check out how to create a Report.

Create a Dashboard

  1. Navigate to the Dashboard page.
  2. Click on the + and it will open the Dashboard wizard. If you haven’t made any Dashboards, the wizard will pop up automatically.
  3. Choose from 3 Dashboard options:
    • Blank: Build a Dashboard from scratch using your own queries.
    • Default Dashboard: Choose one of the pre-built Dashboard Templates we’ve created to provide you with a framework for the data you may be interested in exploring. You can select more than one Default Dashboard at once. When you click Finish you may need to scroll horizontally to find each new Dashboard. You can edit these Dashboards to suit your needs.
    • From Existing Dashboard: Duplicate a Dashboard you have already made. You must have Edit permissions to duplicate an existing Dashboard that another user has created.
  4. Name your Dashboard so you can easily find it later on.
  5. Share your Dashboard, or keep it private until you have finished building it. You have 3 options for user viewing permissions:
    • No Access: Other users will not be able to access the Dashboard.
    • View: The Dashboard will be visible to the user but they won’t be able to make changes to it.
    • View and Edit: The user will be able to edit and delete the Dashboard and change viewing permissions for other users.

Share Dashboards

You must have View and Edit permissions to share a Dashboard.

To share a Dashboard, navigate to the hamburger menu on the top right side of the Dashboard window and select Sharing. Give users the permissions you desire.

 

User Permissions

No Access: Other users will not be able to access the Dashboard.

View: The Dashboard will be visible to the user but they won’t be able to make changes to it.

View and Edit: The user will be able to edit and delete the Dashboard and change viewing permissions for other users.

 

Edit a Dashboard

Edit a dashboard by clicking the hamburger menu on the right hand side of the Dashboard tabs. This menu also provides the option to share or delete a Dashboard.

Once you are in edit mode you can make the following changes to your dashboard:

Add a New Tile

Click Add New Tile in the Dashboard footer. Enter the title for the tile and the query. Click the play button to run the query, then resize and relocate the tile as desired.

 

Edit the Query Displayed in a Tile

Queries can be as broad or specific as you desire. Any queries that you make in Data Chat can be copied and pasted into Dashboard tiles. To get an idea of what kind of queries work best, check out our Query Tips.

To edit a query, just click into the query bar and enter a new query or adjust the current query.

To run the query, click the play button in the top right hand corner of the tile.

NOTE: Dashboard tiles display dynamic data that’s always updated in real time. For example, if you query a non-specific time-frame like “How many of product x did I sell this week?” the tile will display data for the current week. If you check back the following week, the tile will update to display information for that week. If you would like to save and time-stamp data, check out how to create a Report.

 

Edit the Data Source Displayed in a Tile

You can create a Dashboard that will show information from multiple Data Sources. Each tile can display information from a specific Data Source so you can view multiple Data Sources side by side.

To select the Data Source, click the drop down menu with the your available Data Source’s logo beside the query bar and choose the appropriate Data Source.

NOTE: Ensure that the query makes sense for the selected Data Source. For example, you cannot query “What are my Accounts Payable” for an online payment processor like Stripe. To see what queries work for which Data Sources, check out our Query Tips.

 

Edit the Title of a Tile

The title is the name of the tile and should describe the query. To edit the title of a tile, type in the new title and hit Enter

For example, if you query “What was my monthly recurring revenue in 2018” you might choose an easy-to-reference title like “MRR 2018”.

 

Resizing Tiles

The size and shape of the tiles are fully customizable. To adjust the size of the tile, grab the bottom right corner and expand or shrink the tile to the desired size and shape.

Arranging Tiles

Dashboards are fully customizable and can be edited at any time. To arrange the tiles in your Dashboard, grab the tile and move it to your desired location.

 

Delete a Tile

To delete a tile, click the X at the top right of the tile.

If you accidentally delete a tile you can:

Exit the Dashboard and select Exit Without Saving. Any changes you have made will not be saved.

OR

Create a new tile with the same query and visualization.

Viewing Multiple Dashboards

All Dashboards will show up as tabs in the Dashboard page. You can only view one Dashboard at a time.

The first Dashboard in your list will always open by default when you click over to the Dashboard page. You can rearrange the order of your Dashboards by dragging and dropping.

If you have added multiple Dashboards, you can navigate through them by scrolling horizontally.

Downloading & Copying Tiles from a Dashboard

You can easily download an image directly from your Dashboard tile by selecting Save Chart Image.

You can also copy data from a table and paste into other applications like Google Sheets or Excel by selecting Copy Table to Clipboard. 

Delete a Dashboard

You must have View and Edit permissions to delete a Dashboard.

To delete a Dashboard, select the hamburger menu on the top right side of the Dashboard window and select Delete Dashboard.

How to Use Data Visualizations

chata.ai allows the user to visualize their data using graphing/charting functionality. Currently, supported types of visualization tools include “Table”, “Filter table”, “Line chart”, “Pie chart”, “Bar chart”, “Column chart”, “Stacked bar/column chart”, “Bubble chart”, “Heat map.”

Create Dynamic Graphs

When data is returned from a query that chata.ai determines is eligible for graphing/charting, some icons will appear on the top-left corner of the results window to give the user the ability to select a type for visualization.

The user has the ability to dynamically move from the original results to any eligible chart types and then back again if desired. Even after a chart is executed from the query areas, chata.ai will provide options for eligible charting types

Create Visualizations with Queries

You can also ask for a specific chart or graph in a query, for example “total sales per month for the last 18 months in a line graph.”

Drill Down into Your Data

When viewing a query result, there may be times that you want to quickly “drill-down” to see the details. To see the details of a value, just click on the line item, or graph point to drill down and further analyze.

Types of Charts & Graphs

Pivot Table

Filter Table

To filter your data, you must be sure that the data is in “Filter Table” format

Once you are in a filter table, you can select the “Filter” icon in the tool bar. You can filter numbers using numbers and adding terms like “less-than”, “greater-than”, “equal to” and any combination of these symbols. You can also filter by label, for example if you are searching for a specific customer name.

 

 

Line Graph

Pie Chart

Bar Chart

Column Chart

Stacked Bar/Column Chart

Heatmap

Bubble chart

Bubble charts can only be used with queries that include at least three elements. For example: “Total sales per month per customer for the last 6 months” includes 1) total sales 2) per month 3) per customer 4) over the last 6 months.

Word Cloud

Word cloud image

How to Use Cash Flow Forecasting

*This feature is currently available to QuickBooks Online and Xero data sources connections only (as of September 2019)

Cognitive Cash Flow Forecasting uses proprietary algorithms to automatically predict cash flow based on the historical data of an individual business, on a rolling basis. Using AI, this hands-off approach provides users with a low estimated prediction, a high estimated prediction and a most probable prediction, offering a picture of possible futures that reflect the known narrative of a business’ transactional trends. This range of possible outcomes is displayed visually in the cash flow forecast, enabling users to consider possible outcomes and make data-driven decisions about the future of their business with ease.

Cognitive Cash Flow Forecasts are intended for short to mid-term forecasting, allowing predictions up to 6 months, or as little as one week into the future.

The cash flow forecast is derived from two dimensions: cash flow from sales and cash flow from expenditures.

Cash Flow from Sales

Estimates both AR-based sales (outstanding cash sales or invoices owed by a customer) and Cash Sales/non-AR-based sales (cash sales that are paid in full or paid immediately by a customer) and displays probable, low end, and high estimate predictions based on the patterns the system has learned to expect from historical cash and AR-based sales trends of the business.

Cash Flow from Expenditures

Estimates both AP-based expenditures (outstanding cash expenditures or invoices owed by the business) and Cash Expenditures/non-AP-based expenditures (cash expenditures paid in full or paid immediately by the business) and displays probable, low estimate, and high estimate predictions that are based on the patterns the system has learned to expect from historical AP trends of the business.

Calculating Cash Flow Forecasts

The cash flow forecast is an estimate of total cash flow, calculated by taking the estimated cash flow from sales and subtracting the estimated cash flow from expenditures.

Total Cash Flow = Cash Flow from Sales – Cash Flow from Expenditures

Calculating High and Low Estimated Predictions

A high estimated prediction is calculated using the highest possible cash flow from sales and the lowest possible cash flow from expenditures.

High Estimated Cash Flow = Highest CF from Sales – Lowest CF from Expenditures

Likewise, the low estimated prediction is calculated using the highest possible cash flow from expenditures and the lowest possible cash flow from sales.

Low Estimated Cash Flow = Lowest CF from Sales – Highest CF from Expenditures

For example: Jeff’s company is likely to make between $30,000 and $50,000 this month in cash sales and he’s expecting to pay between $15,000 and $20,000 for supplies and labour. His high estimated cash flow prediction would be $50,000 – $15,000 = $35,000. His low estimated cash flow prediction would be $30,000 – $20,000 = $10,000.

Reading a Rolling Forecast

Cognitive Cash Flow Forecasting uses AI and machine learning to generate forecasts based on the historical data of the business. The chata.ai user does not need any experience in forecast generation to use this tool as the forecast is fully automated and displays predictions on a rolling basis.

There are several unique processes taking place behind the scenes to generate these forecasts. Data points are continually ingested into chata.ai’s system and their importance (or their weight) is assessed in the context of each individual business and subsequently factored into the forecast on an ongoing basis.

The system is not only continuously learning from patterns it finds in the data, it is also learning from its own errors (as the forecasted data becomes known) and adjusting itself accordingly. So, as time goes on, forecasts become increasingly accurate.

When it comes to customer behavior in terms of cash sales and AR, the system understands that more recent behaviour patterns are more indicative of future behaviour and weights these data points more heavily. For example, if one of Colleen’s customers has paid their invoices every two weeks for the past year but has begun paying them every three weeks for the last four months, Colleen will see her cash flow forecast change to show that her customer pays every three weeks.

Users can expect to see forecasts that change as a business grows, customer habits fluctuate, and expenses change with the demands of expansion.

Read more about how we built our cash flow forecasting feature and get a behind-the-scenes look at the technology we’ve created.

Making Manual Adjustments

It’s easy to make decisions about the future without making manual adjustments to a Cognitive Cash Flow Forecast. The forecast is always based on the exact patterns the system has learned from historical data rather than what-if scenarios. This means users can be sure that the forecast they are looking at accurately represents the truth about their business, and what’s most likely to happen based on that truth.

While our intention is to provide an automated forecast that does not support extensive scenario modeling, we also understand that non-predictable and one-off events do happen. To account for this, users can make some manual adjustments to their cash flow forecasts. We recommend using this function of the feature to view forecasts in the context of information you may be privy to that the machine does not yet know, or to visualize the impact of other unpredictable events.

Adjustments to forecasts can only be made in Data Chat and Templates not in other features of the app (namely, Dashboards and Reports).

In order to make manual adjustments, follow these steps:

  • Input your forecasting query (Check out our Query Tips)
  • When your cash flow forecast has been returned to you, navigate to the table below the graph and click the ‘Adjust’ icon on the left hand side.
  • Adjustments can be entered manually in the ‘Adjustment’ rows, highlighted blue. Simply click the cell you wish to add your adjustment to, type in the desired adjustment and hit Enter. Ensure that the number you’ve entered is accurate.
  • To finish and return to the newly adjusted forecast, click the X in the top right hand corner of the screen.

 

Important Tips 

If you are anticipating a one-off low expenditure event, you would enter that value under the High Estimate column in the ‘Adjustments – Cash Flow from Expenditure’ row. A one-off high expenditure event would be entered in to the same row under the Low Estimate column.

Likewise, if you are anticipating a one-off low sales event, you would put that value under the Low Estimate column in the ‘Adjustments – Cash Flow from Sales’ row.

Read more about how high and low estimated predictions are calculated.

Viewing Cash Flow Graphs

Zoom View

To zoom in on a section of the cash flow forecast graph, click and drag your cursor to create a box over the area you wish to zoom into.

Zoom gif

Viewing Individual Line Graphs

Isolate Probable, High Estimate, and Low Estimate lines by clicking on the labels in the key at the bottom of the graph.

viewing individual line graphs

Is Your Data Compatible with Our System?

Cognitive Cash Flow Forecasting is based entirely on historical data and the patterns of transactional-level data as it’s ingested into the system.

Our cash flow forecast will not work for you if:

  • There is not enough data present or if the data is “bad.”
    • If there is not a substantial amount of historical data available, or the data available lacks detail, the forecast will not be able to give an accurate prediction.
  • The ongoing data input lacks detail or is isn’t inputted consistently into the cloud accounting system that it draws from.
    • The most accurate forecasts emerge from consistent input of transactional data. For example, if your Data Source is updated once a month with all of the sales from the previous 30 days reflected only as one single payment, the forecast will display one single spike in income and make predictions based on that pattern repeating over time. This is not an accurate reflection of the business’ cash flow, as the sales that happened within those 30 days are reflected as a single data point rather than individual occurrences.

Billing & Licences

Upgrade a Data Source to Premium

After you purchase licenses, you will need to be sure to turn the selected data source to premium by toggling the premium button to on.

 

Purchase Licences

You will only have the option to purchase and cancel licenses if you are the payment manager. Select “Purchase Licenses” on the bottom right hand side of the User Administration page.

 

 

Select if you want to be billed annually or monthly

 

 

 

Choose how many licenses you would like to purchase. A license will be consumed by 1 user in 1 data source. Select “Pay with Card,” enter your details and subscribe to chata.ai.

Assign a Purchased Licence

To assign a license, simply check the box beside the user’s name under the appropriate data source.

View Your Purchase Summary

To view a breakdown of your bill for current licenses, navigate to the “Purchase Summary” tab in Settings. You will be able to view a summary of the licenses purchased and assigned to specific organizations. *Note: You will only be able to view the Purchase Summary of your own purchases.

Suggest Edit